Click here to sign up  Click here to go to the galleries  Click here to go to the code of conduct  Click here to go to the video page  Click here to go to the SW Meets page
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12

Thread: Wrong Battery??

  1. #11 Re: Wrong Battery?? 
    club member Club Member chris_cussen's Avatar
    Join Date
    Nov 2011
    Location
    South Somerset
    Posts
    639
    Well!
    I've got a budget Drivetech battery (whoever they are) which is rated at 40AH and 330CC.
    It worked OK for the DOHC Sierra engine, and using the same starter motor with the Zetec engine works OK too.
    I did have an issue of poor starting in cold weather, and finally traced it to the engine to battery earth cable, which is now replaced with two cables running straight from the battery to the engine.
    Cabrio, Omex 2.0l 170bhp Zetec blacktop, Omex ECU and wiring loom.
    Reply With Quote  
     

  2. #12 Re: Wrong Battery?? 
    club member Club Member
    Join Date
    Nov 2011
    Location
    Suffolk
    Posts
    529
    Unfortunately I can't fit the 24cm long battery in my car without significant changes like moving the fusebox. I'm hoping the 21cm long battery with its higher cranking current will improve things. I already replaced the earth lead with a new thicker one and doubled up on the positive lead to the starter solenoid. The starter motor was checked not too long ago and I don't think its gone faulty because it spins the engine over very well on the occasions when I've needed a jump start. Fingers crossed the higher performance battery works!!
    Reply With Quote  
     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •